Xsan Volume Mounted but Hidden In Finder

mrmacmike's picture

Here is a new one for me. Volume is mounted on xsan 2.3. Works perfectly if I navigate to the volume manually (Go to Folder > /Volumes/Drivename). I can still use Final Cut. However, the volume is HIDDEN in the system! I have tried sudo chflags -R nohidden /Volumes/Drivename but it doesn't help. I have tried removing all clients and unmounting/repairing volume using cvfsck. Then apply chflags trick. Still doesn't help.

Any help is much appreciated!

mrmacmike's picture

BUMP!!

joemillerftw's picture

I'm experiencing the same issue on an Xsan 3 Mountain Lion environment. Have you had any luck?

abstractrude's picture

post system log while issues happening. also post df -a

-Trevor Carlson
THUMBWAR

joemillerftw's picture

abstractrude wrote:
post system log while issues happening. also post df -a/quote

I actually ended up paying Apple to fix it because it's totally brought production to a halt as Final Cut Pro can no longer see the volume. However, I will post Apple's solution here later today once it's resolved.

mrmacmike's picture

So what did they do to fix it? Still no answer

mrmacmike's picture

df -a output
[url]http://www.megafileupload.com/en/file/410575/df-export-txt.html/url

System Log
[url]http://www.megafileupload.com/en/file/410576/Edit2-System-Log-log.html/url
on this one change the extension to .log (take the .html off)/code

mrmacmike's picture

HEEEEELP!

watchdog's picture

Hi,
we fixed it. The root directory got an extended attribute key which we deleted with xattr.

thunder:Volumes root# pwd
/Volumes
thunder:Volumes root# ls -l@
...
drwxrwxrwx 19 root wheel 10240 Apr 23 10:47 Owl
com.apple.FinderInfo 32
thunder:Volumes root# xattr -d com.apple.FinderInfo Owl

Kind regards,
Martin

mrmacmike's picture

That was it!

Less confusing answer:

xattr [i]/VolumeName/i

Whatever attribute file is listed, delete it.

xattr -d [i]com.apple.FinderInfo BLABLABLA/i

Hope this helps someone else!

halimedia's picture

What happens is that something (I'd very much like to know what, when and how) changes the visibility attribute of the volume. This can also happen to files and folder within a volume, but I've seen it more frequently at the volume-level since Xsan 3. Xcode contains the CLI utility SetFile, which allows manipulating file attributes. This will make a volume visible again:

sudo SetFile -a v /Volumes/MyXsanVolume

HTH,

Ron